Portal:Hardware/PowerbeamM2XW

Aus Freifunk Franken

Infos

Die Powerbeam M2 ist ein Richtfunkgerät welches ähnlich wie eine Satellitenschüssel aussieht und etwa 40cm Durchmesser hat. Mit einer angegeben Sendeleistung von max. 28dBm (laut OpenWRT iwconfig allerdings selbst mit US Einstellung nur 22dBm) und einer 18dBm Antenne sowie einen sehr kleinen Öffnungswinkel ist sie sehr gut für Punkt zu Punkt Verbindungen geeignet. Laut OpenWRT Webseite gibt es in der Hardwarefassung XW einen Bug der den Ethernetanschluss unbrauchbar macht. Ich habe den Ethernetport durchgetestet und konnte den Bug nicht feststellen. Somit ist der Ethernetboard wie bei allen anderen Geräten mit nur einem Port frei über die network.mode konfigurierbar.

Hersteller

Infos

Datenblatt

Infos zum flashen

Die Powerbeam M2 wurde mir mit der AirOS Version 5.6.2 ausgeliefert. Da es auf OpenWRT Berichte gibt, nachdem man auf AirOS 5.6.X kein OpenWRT flashen darf [1] [2], war ein downgrade nötig. Leider bietet Ubiquiti keine 5.5.X Version für die Powerbeam an [3]. Nach einigen googlen stieß ich auf Informationen das die Powerbeam M2 XW von der Hardware baugleich mit der Nanobeam M2 sein soll. Somit hab ich es riskiert und die Ubiquiti 5.5.10-u2 Firmware für die Nanobeam M2 geflasht [4]. Dies gelang problemlos und ich hatte nun eine Powerbeam M2 5.5.10-u2 auf welche sich anschließend problemlos die Freifunkfirmware flashen lies und auch problemlos läuft. Diese Prozedur muss im Zweifelsfall im Einzelfall abgewogen werden. Mir ist nicht bekannt ob es die Powerbeam M2 auch als XM Hardware gibt (sollte dem so sein, wird diese Firmware höchstwahrscheinlich nicht funktionieren) oder ob sie mit AirOS 5.5.X ausgeliefert wird. Genauso wenig ist mir bekannt ob das flashen von OpenWRT auf AirOS 5.6.X nur bei XM Geräten oder auch bei XW Geräten nicht funktioniert und man das Gerät bricked. Flashen hier auf eigene Gefahr!

Weiterhin hab ich bisher niemanden gefunden der bereits die Powerbeam M2 mit OpenWRT ausgestattet hat, u.U. bin ich der erste gewesen und daher gibt es hier nur sehr wenig Infos. Die Information im OpenWRT Wiki welche Firmware funktioniert stammt von mir [5], ich hab dies durch ausprobieren gelöst, daher ist es gut möglich das evtl. eine andere Firmware auch oder u.U. sogar besser funktioniert.

Der Bug nachdem die Ethernetschnittstelle bei XW Hardware nach einigen Stunden nicht mehr funktioniert [6] konnte bei mir nicht nachgestellt werden. Auch nach über 24 Stunden im Einsatz tat es die Ethernetschnittstelle problemlos.

Firmware

Für die Firmware wurde grundsätzlich die Funktionen der Nano/Picostation herangezogen. So kann auch hier der Ethernetport konfiguriert werden über die network.mode. Anleitung dazu hier

Anpassungen in der Firmware

Boardname

Da die Ausgabe von

cat /var/sysinfo/board_name

nur

loco-m-xw

lautet würde das Updatescript fehlschlagen da es nach

openwrt-ar71xx-generic-loco-m-xw-squashfs-factory.bin

sucht, die Datei aber eigentlich

openwrt-ar71xx-generic-ubnt-loco-m-xw-squashfs-factory.bin

heißt. Dies wurde in der rc.local gefixt:

...
    loco-m-xw)
        BOARD=ubnt-loco-m-xw
        ;;
...

Diese Änderung muss auch in der network config durchgeführt werden, so heißt die Datei nun

/etc/network.ubnt-loco-m-xw

Anpassung MTU

Da aus bisher unbekannten Gründen das eth0 Interface standardmäßig mit einem MTU von 1532 versehen wurde und dies bei vielen Tests nicht wirklich geklappt hat, wurde dies mit der Zeile

...
uci set network.eth0.mtu="1500"
...

in der /etc/network.ubnt-loco-m-xw gefixt und der MTU auf 1500 festgesetzt. Probleme mit MTU 1532 waren u.A. das Alfred keine Daten gesendet hat und der Router im Monitoring offline bliebt sowie SSH Sessions die über das LAN Interface liefen welche beim Abruf von mehreren Daten einfach abgebrochen sind.