Standorte/Fuerth/Hardhöhe/Heilig Geist Kirche

Aus Freifunk Franken

Dieser Standort ist in Betrieb!
Der Standort ist in Betrieb. Der tatsächliche Status der Anlage kann im Monitoring überprüft werden.

Details

Status

  • 27.06.2017 Besichtigung und Planung
  • 11.07.2017 Geräte für Kirche konfiguriert
  • 13.07.2017 EP-R6, NBE-5AC-16 und 4 NSM2 auf dem Kirchturm aufgebaut, kleinere Optimierungen müssen noch folgen
  • 18.07.2017 2 Archer c7 im Nachbargebäude untergebracht, Mesh ist ok aber nicht sonderlich schnell
  • 23.07.2017 Speedtests vor Ort sind ok, je nach Position sind überall mindestens ein paar Mbit/s drinnen, manchmal besser, manchmal bisschen schlechter aber es funktioniert grundlegend gut.
  • Dezember 2017/Januar 2018: Am Kirchturm eine LBE-5AC-16-120 Richtung NordOst montiert. EG1 mit einer NSMLoco5 An den Sektor angebunden. NSM2 in Richtung NordOst von Kanal 13 auf Kanal 5 geändert um 13 im Gebäude frei zu haben. Im Gebäude ist es nun problemlos möglich meinen 50Mbit/sec VDSL Anschluss auszulasten.
  • 01.03.2018 Gateway auf der Kirche montiert, wasserdichte Box erneuert, Update der Nanostations (eine ist dabei gestorben, wurde daheim wieder repariert und wird demnächst wieder montiert), Update der NBE-5AC-16, weitere NBE-5AC-16 Richtung StPaul installiert, VLANs umgestellt.

Hoodfile

{
   "version":1,
   "network":{
      "ula_prefix":"fd43:5602:29bd:17:\/64"
   },
   "vpn":[

   ],
   "hood":{
      "name":"hard",
      "essid":"hard.freifunk",
      "mesh_bssid":"ca:ff:ee:ba:be:06",
      "mesh_essid":"hard.mesh.ff",
      "mesh_id":"hard.mesh.ff",
      "protocol":"batman-adv-v15",
      "channel2":"1",
      "mode2":"ht20",
      "mesh_type2":"802.11s",
      "channel5":"36",
      "mode5":"ht20",
      "mesh_type5":"802.11s",
      "upgrade_path":"",
      "ntp_ip":"fd43:5602:29bd:ffff::1",
      "timestamp":"1507655045",
      "location":{
         "lat":"49.479287",
         "lon":"10.954822"
      }
   }
}

Aufbau

eine NBE-5AC-16 wird an der Kirche Richtung DB0FUE montiert. Auf VLAN Tag 8 wird Babel reingeholt. Ein EP-R6 verteilt Batman auf 4 NSM2. Es sind jeweils 2 NSM hintereinander geschaltet um Ports zu sparen. In einer wasserdichten Box ist ein wdr4900 als Gateway und ein Netzteil sowie eine Mehrfachsteckdose. Eine LBE-5AC-120-16 ist Richtung NordOst ausgerichtet montiert.

Nebenan im Gebäude wurden 2 Archer C7 v2 platziert. An einem Archer C7 hängt eine NSMLocoM5 welche zu der LBE-5AC-120-16 auf der Kirche verbunden ist.

Die Verbindung zwischen HGK und Hochhaus liegt auf einen Sektor am Hochhaus und ist mit -55dbm bei 40MHz voll im 256QAM. Geschwindigkeit wurde nie wirklich ermittelt.

Bilder

Abdeckung

Diverse Configs

Gateway

  • ToDo

VLAN & Port config

  • 1
    • Batman
    • aktuell frei
  • 2
    • VLAN 8t, VLAN 16t, VLAN 1
    • Babel zur Hardhöhe (über EP-R6) VLAN 8 tagged
    • Batman VLAN 16 tagged
    • Client VLAN 1 untagged
  • 3
    • VLAN 1 Client
    • VLAN 9t
    • Babel StP
    • NBE-5AC-16 ist montiert,
  • 4
    • VLAN 1 Client
    • VLAN 10t
    • aktuell frei
  • blauer Port
    • Clientzugang zu Gateway
    • aktuell frei

configs

root@fff-gw-hgk:/www/hood# cat /etc/config/gateway 
config version
	option config_version '1'

config gateway
	option name 'fff-gw-hgk'

config vlan '1'
	option comment 'client'
	option ports '1 3 4 5'

config vlan '16'
	option comment 'batman'
	option ports '2 3t'

config vlan '8'
	option comment 'fffgwhh'
	option ports '3t'

config vlan '9'
	option comment 'fffgwstp'
	option ports '4t'

config vlan '10'
        option comment 'fffgweual'
        option ports '5t'

config client
	option vlan '1'
	option ipaddr '10.83.48.1/22'
	option dhcp_start '10.83.49.0'

config dns
	list server '10.83.252.11'
	list server '10.50.252.0'

config batman
	option vlan '16'

config babelpeer 'fffgwhh'
	option vlan '8'
	option type 'wired'

config babelpeer 'fffgwstp'
	option vlan '9'
	option type 'wired'

config babelpeer 'fffgweual'
        option vlan '10'  
        option type 'wired'
root@fff-gw-hgk:/www/hood# cat /www/hood/keyxchangev2data 
{"version":1,"network":{"ula_prefix":"fd43:5602:29bd:17:\/64"},"vpn":[],"hood":{"name":"hard","essid":"hard.freifunk","mesh_bssid":"ca:ff:ee:ba:be:06","mesh_essid":"hard.mesh.ff","mesh_id":"hard.mesh.ff","protocol":"batman-adv-v15","channel2":"1","mode2":"ht20","mesh_type2":"802.11s","channel5":"36","mode5":"ht20","mesh_type5":"802.11s","upgrade_path":"","ntp_ip":"fd43:5602:29bd:ffff::1","timestamp":"1507655045","location":{"lat":"49.479287","lon":"10.954822"}}}

Config EP-R6

  • eth0: hier hängt das Gateway dran, es darf PoE NICHT aktiviert werden
    • PVID: 1
    • VID: 8, 16
  • eth1: tagged VLAN 8 (NBE-5AC-16) Babel, untagged VLAN 1 remote Zugang seitens der Kirche
    • PVID: 1
    • VID: 8
  • eth2: untagged VLAN 16 (erstes Pärchen NSM2) Batman
    • PVID: 16
  • eth3: untagged VLAN 16 (zweites Pärchen NSM2) Batman
    • PVID: 16
  • eth4: untagged VLAN 1 (LBE-5AC-16-120 Sektorzugang NO)
    • PVID: 1
    • VID: 16
  • eth5: Sollten die Ports ausgehen, kann ein 2. EP-R6 montiert werden und per SFP mit dem ersten zusammen geschaltet werden. In der wasserdichten Box beim wdr4900 ist noch Platz für PoE Injektoren und kann auch verwendet werden da am wdr4900 noch Ports frei sind.

Config der NBE-5AC-16

  • Bridge Mode im Expertenmodus
  • LAN0 ist Managmentinterface
  • LAN0.8, WLAN0.8 in einer zweiten Bridge hier wird Babel auf WLAN0.8 von der Hardhöhe geholt und auf LAN0.8 tagged auf das Kabel ausgegeben

Config der 2. NBE-5AC-16

  • Bridge Mode im Expertenmodus
  • LAN0 ist Managmentinterface
  • LAN0.9, WLAN0.9 in einer zweiten Bridge hier wird Babel auf WLAN0.9 von StPaul geholt und auf LAN0.9 tagged auf das Kabel ausgegeben
  • ACHTUNG: Hardware gehört RedDog und ist nur geliehen!

Config der LBE-5AC-16-120

  •  !! ACHTUNG: Eigentum von dk5ras !!
  • LAN0 + WLAN0 Bridge -> Managment
  • LAN0.16 + WLAN0-16 Bridge -> Batman
  • PtMP AirMAX Mixed Mode
  • 5560 - 5580MHz (20MHz)

Config der Nanostation Loco M5

  •  !! ACHTUNG: Eigentum von meskal !!
  • WLAN0+LAN0.222 in BRIDGE0 -> Managment
    • Wenn man per Kabel drauf will, muss man am Kabel das VLAN 222 taggen!
  • LAN0 + WLAN0.16 in BRIDGE1 für Batman
    • Kann normal an einen Freifunkrouter angeschlossen werden
  • MPtP Airmax Mixed Zugang über LBE-5AC-16-120

NSM2

  • Es wurde die adsc2_20180226 Firmware geflasht [1]
  • Es wurden Kanäle über die Sektorfile angepasst [2]
  • Ansonsten sind sie Standart konfiguriert

Archer C7 v2

  • Es wurde eine spezielle Firmware aus den Commit d8a2b788569acae2f000a7ead58d90b3b73c776c kompiliert. Dabei wurde das Buildscript angepasst und kmod-batman-adv-legacy entfernt und dafür das Paket kmod-batman-adv hinzugefügt. Es wurde aktuell Batman 2016.5 verwendet auf LEDE Basis. Ein Update auf neueres Batman kann später getestet werden.
  • 11b wird auf 2,4GHz deaktiviert um Airtime zu sparen
set wireless.radio1.supported_rates='6000 9000 12000 18000 24000 36000 48000 54000'
set wireless.radio1.basic_rate='6000 9000 18000 36000 54000'
  • Hotfix für Hostname
  • SSID, BSSID und SSID von AdHoc wurden angepasst
  • Kanalanpassungen und Abschaltung eventueller Meshinterfaces muss im laufenden Betrieb getestet werden.

Alle Einstellungen wurden über die /etc/rc.local.fff_userconfig Update und Rebootfest gemacht:

uci set wireless.radio1.supported_rates='6000 9000 12000 18000 24000 36000 48000 54000'
uci set wireless.radio1.basic_rate='6000 9000 18000 36000 54000'
uci set wireless.w2ap.ssid=hard.freifunk
uci set wireless.w2mesh.bssid='CA:FF:EE:BA:BE:05'
uci set wireless.w2mesh.ssid='batman.hard.freifunk'
uci set wireless.radio1.channel='13'
uci set wireless.w5ap.ssid=hard.freifunk
uci set wireless.w5mesh.bssid='CA:FF:EE:BA:BE:05'
uci set wireless.w5mesh.ssid='batman.hard.freifunk'
uci set wireless.radio0.channel='{36}{48}'
uci set wireless.radio0.htmode='VHT40'
uci commit                                                            
wifi                                                                  
echo $(uci get system.@system[0].hostname) > /proc/sys/kernel/hostname